Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1
    Member Pudderz's Avatar
    Join Date
    Mar 2016
    My Ride
    Iron883
    Posts
    23
    Thanked: 0

    Dash board Leds on iron 883

    Hi all has anyone had any problems with the Leds on the dash board keeps blowing when you get caught in heavy rain this is the second time this has happened not too impressed has I have had Japanese bikes and British bikes and had no problems before this is my first American bike and you get this problem

    Sent from my SM-G935F using Tapatalk

  2. #2
    Senior Member Whistler's Avatar
    Join Date
    Mar 2016
    My Ride
    2016 Harley-Davidson 883 iron
    Posts
    3,011
    Thanked: 516
    Been out in some heavy rain on the Iron, not experienced this. Take it the dealer and get them to sort it if bikes under warranty.
    FTW )

  3. #3
    Member Pudderz's Avatar
    Join Date
    Mar 2016
    My Ride
    Iron883
    Posts
    23
    Thanked: 0
    Quote Originally Posted by Whistler View Post
    Been out in some heavy rain on the Iron, not experienced this. Take it the dealer and get them to sort it if bikes under warranty.
    Thanks will do can't believe this has happened again will keep all updated

    Sent from my SM-G935F using Tapatalk

  4. #4
    Senior Member Whistler's Avatar
    Join Date
    Mar 2016
    My Ride
    2016 Harley-Davidson 883 iron
    Posts
    3,011
    Thanked: 516
    Wouldn't worry bout it to much. Harleys are not like other bikes. They are bikes you need to be more involved with re maintenance etc. Most dealers are good at getting things sorted quickly and your problem is probably just a sealing issue. Don't be put off cause the riding time out ways everything else.
    FTW )

  5. #5
    Senior Member K9F's Avatar
    Join Date
    Dec 2015
    Location
    South Coast
    My Ride
    FXSE CVO BREAKOUT
    Posts
    2,755
    Thanked: 829
    If I can recall correctly somebody else had water ingress issues with the instrument cluster on here?

    **EDIT**

    http://harleyforum.org.uk/showthread...=water+cluster

    http://www.harley-davidsonforums.com.../271370?page=1
    Last edited by K9F; 01-17-2017 at 06:30 PM.

    IF YOU GO THROUGH LIFE WITH YOUR HEAD IN THE SAND.....ALL PEOPLE WILL SEE IS AN ARSE!!
    TREAT EVERY DAY AS YOUR LAST.....ONE DAY YOU WILL BE RIGHT!!

  6. #6
    Member Pudderz's Avatar
    Join Date
    Mar 2016
    My Ride
    Iron883
    Posts
    23
    Thanked: 0
    Quote Originally Posted by K9F View Post
    If I can recall correctly somebody else had water ingress issues with the instrument cluster on here?

    **EDIT**

    http://harleyforum.org.uk/showthread...=water+cluster

    http://www.harley-davidsonforums.com.../271370?page=1
    Went to the shop yesterday and they sorted the led cluster out it was the seal that blow all replaced and got another year warranty as well thanks for your replies now I can do some happy riding and ride like it meant to be ridden once the bad weather is over I can start doing all my upgrades

    Sent from my SM-G935F using Tapatalk

  7. #7
    Senior Member Whistler's Avatar
    Join Date
    Mar 2016
    My Ride
    2016 Harley-Davidson 883 iron
    Posts
    3,011
    Thanked: 516
    Sounds like a result. I've found most dealerships I've come across to be very helpful and accommodating. Enjoy getting out and about.
    FTW )

  8. #8
    Senior Member Dod's Avatar
    Join Date
    May 2016
    Location
    Perth and Kinross
    My Ride
    Harley-Davidson Streetbob SE
    Posts
    1,568
    Thanked: 287


    I had something kinda similar on my bike..from the picture you can see the panel on my bike started to shatter due to vibrations and got replaced under warranty


    Sent from my iPad using Tapatalk

  9. #9
    Member Pudderz's Avatar
    Join Date
    Mar 2016
    My Ride
    Iron883
    Posts
    23
    Thanked: 0
    Quote Originally Posted by Dod View Post


    I had something kinda similar on my bike..from the picture you can see the panel on my bike started to shatter due to vibrations and got replaced under warranty


    Sent from my iPad using Tapatalk
    Bloody he'll dodgy the vibration did that!!!

    Sent from my SM-G935F using Tapatalk

  10. #10
    Senior Member Dod's Avatar
    Join Date
    May 2016
    Location
    Perth and Kinross
    My Ride
    Harley-Davidson Streetbob SE
    Posts
    1,568
    Thanked: 287
    Quote Originally Posted by Pudderz View Post
    Bloody he'll dodgy the vibration did that!!!

    Sent from my SM-G935F using Tapatalk
    Just a poor fit and a weak point in it i was told. Replaced under warranty and no issues with it after so all is good..

    Sent from my LG-H850 using Tapatalk

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •